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Overview 
 

The Pelco Viewer enables operators to have video streamed onto their 
CitectSCADATM screens directly from PelcoTM IP camera located across various 
locations in the plant. The Pelco Viewer is an ActiveX® component which can be 
inserted into a SCADA graphics page and configured with a range of camera 
properties.  
 

This Chapter Covers These Topics: 

 Training Overview ................................................................. 1-2 

 Conventions Used in this Manual .......................................... 1-4 
 
 

Chapter 1: Introduction to the Pelco Viewer 

Introduction 
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Training Overview 
 

This training guide is a supplement to the authorised training. To read further 
information, students should also refer to the Pelco Camera and SCADA 
Integration Guide (available from the Windows® Start menu: Start » Programs » 
Schneider Electric » Pelco »  Pelco User Guide). 

The graphics displaying screen shots have been taken using the Windows® XP 
operating system using Classic mode display properties. If students are running a 
different version of Windows, then screens may differ slightly from the ones shown 
in the training guide. 

Some screen shots may have been taken from beta versions of the software and may 
vary slightly from release screen shots.  
 
 

By the completion of this training guide students will successfully demonstrate that 
they can: 

 Install and configure the Pelco Viewer. 
 Connect to a Pelco IP camera and view live video feed in a CitectSCADA 

project. 
 Perform camera control operations such as Pan, Tilt and Zoom (on cameras 

which support these features) at runtime. 
 Use event-triggered display features such as Patterns, Presets etc. 
 Create a Pelco Viewer interface in a graphics page, configure basic camera 

properties and create camera control objects. 
 
 

The Pelco Camera and CitectSCADA Integration training guide is an integral part 
of the complete Educational Services curriculum. This course is designed for: 

 Plant supervisors, site managers, and operators who perform surveillance and 
remote monitoring & control functions. 

 Experienced SCADA users who have no experience with camera integration in 
SCADA products. 

 

The Pelco Camera and CitectSCADA Integration training guide is set at the 
Intermediate level within the Educational Services curriculum. Therefore, some 
prerequisite knowledge is necessary before enrolling in this course. 

 Students attending this course are familiar with Windows Operating Systems. 
 Students have attended the CitectSCADA Configuration course or are familiar 

with the content and concepts within this course. 
 

Scope of this 
Training Guide 

Training 
Objectives 

Target Audience 

Prerequisite 
Knowledge 
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Training Overview (cont.) 
 

For this training, in addition to the standard CitectSCADA software and the Pelco 
Viewer ActiveX control, the following file is required: 

PelcoExample720 An included project containing additional 
resources, compatible with CitectSCADA v7.20. 

It is assumed that students have access to a supported Pelco camera, ideally a 
camera that supports the Pan, Tilt and Zoom features. 
 
 

The training guide will take approximately 2 hours to complete. It is available as a 
self-paced training guide and may also be covered in one of the Educational 
Services instructor-led courses. 
 

Training Assets 

Training 
Program 
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Conventions Used in this Manual 
 

These are the skills to be achieved by the end of each chapter.  An overview 
providing a brief synopsis of the topic begins each section.  Often, examples are 
given to illustrate the conceptual overview. 

Example - 

The CitectSCADA configuration environment consists of several toolbars, browser 
windows and programming editors.  This chapter introduces the user to the 
configuration environment using an example project with pre-defined elements. 

 
 
 

After a concept is explained students will be given exercises that practise the skills 
just learned. These exercises begin by explaining the general concept of each 
exercise and then step-by-step procedures are listed to guide students through each 
procedure. 

Example - 

Paste a genie from a library in the Include project onto a test page called Utility. 

1 Run the Milk_Upgrade project then trigger and view some alarms. 

i. Use the following template settings: 
 
 
 

Whenever information is to be typed into a field or dialog box it will be written in 
this font: 

Example - 
KETTLE_TEMP/25 

Note that some exercises will show a fragment of information already typed into a 
CitectSCADA screen and then ask students to add extra lines of configuration.  In 
this instance, the previously entered material will be given to the student as pale 
grey italic text: 
 

KETTLE_TEMP/25 

OVEN_TEMP/5 
 

Objectives 

Exercises 

User Input 
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Conventions Used in this Manual (cont.) 
 

This heading will provide students with useful or helpful information that will make 
configuring the project easier. 

Example - 

 Hints & Tips 

To go to the next field, use the mouse cursor or press the TAB key. 

 
 
 

A note will refer to a feature which may not be obvious at first glance but 
something that should always be kept in mind. 

Example - 

 Note: 

Any events named GLOBAL are enabled automatically when events are enabled. 

 
 
 

Text separated by the double arrow symbol “»” indicates that users are to select a 
menu item. 

Example - 
File » New… 

Open a menu “File” then select the menu option “New…” 
 
 
 

Text written this way indicates the Horizontal then the (Vertical) tab is to be 
selected. 

Example - 
Appearance (General) 
 
 

Hints & Tips 

Note 

Menus and Menu 
Options 

Horizontal and 
Vertical Tabs 
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Conventions Used in this Manual (cont.) 
 

Text written in this way indicates further references about the current topic. 

Example - 

 See Also: 

For further information about Templates, see CitectSCADA Help - Using Page 
Templates. 

 
 
 

This heading describes topics that are covered in more advanced courses. 

Example - 

 Further Training: 

Alarm Filtering is a topic in the CitectSCADA Customisation and Design 
Course. 
 
 

See Also 

Further Training 
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Conventions Used in this Manual (cont.) 
 

Hazard categories and special symbols 

The following symbols and special messages may appear in this manual or on the 
product to warn of potential hazards or to call attention to information that clarifies 
or simplifies a procedure.  

A lightning bolt symbol in a "Danger" or "Warning" safety label on the product 
indicates an electrical hazard which, as indicated below, can or will result in 
personal injury if the instructions are not followed. 

The exclamation point symbol in a safety message in a manual indicates potential 
personal injury hazards. Obey all safety messages introduced by this symbol to 
avoid possible injury or death. 

Symbol Name 

 
Lightning Bolt 

 
Exclamation Point 

 
 
 
 

 
DANGER indicates an imminently hazardous situation, which, if not avoided, will 
result in death or serious injury. 

 
 
 
 

 
WARNING indicates a potentially hazardous situation, which, if not avoided, can 
result in death or serious injury. 

 
 
 
 

 
CAUTION indicates a potentially hazardous situation which, if not avoided, can 
result in minor or moderate injury. 

 
 
 
 

 
CAUTION, used without the safety alert symbol, indicates a potentially hazardous 
situation which, if not avoided, can result in property damage. 

 
 

Please Note 

Electrical equipment should be installed, operated, serviced, and maintained only 
by qualified personnel. No responsibility is assumed by Schneider Electric for any 
consequences arising out of the use of this material. 

Safety 
Information 
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Conventions Used in this Manual (cont.) 
 

Before You Begin 

CitectSCADA is a Supervisory Control and Data Acquisition (SCADA) solution. It 
facilitates the creation of software to manage and monitor industrial systems and 
processes. Due to CitectSCADA's central role in controlling systems and processes, 
you must appropriately design, commission, and test your CitectSCADA project 
before implementing it in an operational setting. Observe the following: 

 
UNINTENDED EQUIPMENT OPERATION  

Do not use CitectSCADA or other SCADA software as a replacement for PLC-based 
control programs. SCADA software is not designed for direct, high-speed system 
control.  

Failure to follow these instructions can result in death, serious injury, or 
equipment damage. 

 
 
 
 

 
LOSS OF CONTROL  

• The designer of any control scheme must consider the potential failure 
modes of control paths and, for certain critical control functions, provide a 
means to achieve a safe state during and after a path failure. Examples of 
critical control functions are emergency stop and overtravel stop. 

• Separate or redundant control paths must be provided for critical control 
functions. 

• System control paths may include communication links. Consideration 
must be given to the implications of unanticipated transmission delays or 
failures of the link.* 

• Each implementation of a control system created using CitectSCADA must 
be individually and thoroughly tested for proper operation before being 
placed into service. 

Failure to follow these instructions can result in death, serious injury, or 
equipment damage. 

 
 
 
 

 
UNINTENDED EQUIPMENT OPERATION 

Integration of Pelco camera streaming with CitectSCADA is provided as an aid and 
is not intended to replace a complete security monitoring system. 

Failure to follow these instructions can result in death, serious injury, or 
equipment damage. 

* For additional information, refer to NEMA ICS 1.1 (latest edition), "Safety 
Guidelines for the Application, Installation and Maintenance of Solid State 
Control".  

 

Safety Information 
(cont.) 



 

 

Overview 
 

The Pelco Viewer is designed for the integration of Pelco IP cameras on 
CitectSCADA screens, with real-time video streaming and control. User-friendly 
controls like Pan, Tilt, Zoom (PTZ) and event-triggered display features make the 
Pelco Viewer an intuitive set of 'eyes on site' for the operators.  
 

By the end of this chapter, students will be able to: 

 Install the Pelco Viewer. 
 Explain what an IP camera is and how it works. 
 Navigate in the Pelco Example project and connect to a camera. 
 Effectively operate the Pelco Viewer viewing and control features at runtime. 
 
 
 
 
 
 
 

This Chapter Covers These Topics: 

 IP Cameras and Video Surveillance ...................................... 2-2 

 Supported Cameras ................................................................ 2-3 

 System Requirements ............................................................ 2-5 

 The Pelco Viewer Installation................................................ 2-7 

 Connection to a Camera ......................................................... 2-9 

 Pan, Tilt and Zoom Controls ............................................... 2-16 

 Further Controls and Viewing Features ............................... 2-19 
 
 

Chapter 2: Exploring the Pelco Viewer and its features 

Introduction 

Learning Outcomes 
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IP Cameras and Video Surveillance 
 

IP camera stands for Internet-Protocol camera. It is a type of digital video camera 
commonly used for surveillance, often also called "network camera" or "IP network 
camera" 

An IP camera is a stand-alone device. It can be described as the combination of a 
camera and a computer in one unit, where functionality required for controlling, 
monitoring and viewing images from any location via the network or the Internet is 
built in. 
 
 

 

The camera component captures the image and transforms it into electrical signals 
- the lens capture and focus beams of light to create the image. Instead of focusing 
the light information onto film, the camera filters its colors to remove any infrared 
light and focuses onto an image sensor which scans the image and transforms the 
light information into electrical signals. Then, an encoder converts these analog 
electrical signals into a digital format.  

The IP camera has its own IP address and built-in computing function to handle 
network communication. The digital signals are finally transferred into the 
computer component where the image is compressed before being sent out over 
the network as live video streams. 
 
 

By complementing I/O data with visual information, real-time video surveillance in 
CitectSCADA assists the operators in effectively supervising the security of their 
plant and assets as well as their personnel.  

Consider a water utility with a multitude of pump stations dispersed across 
hundreds of kilometers. If a leakage of dosing chemical at a water supply facility is 
detected, video will show the scale and nature of the problem more intuitively than 
I/O data alone, and help alert operators to the possible risks at the site.  

In the case of an oil field, if a suspicious entry into a remote pipeline or a 
malfunction in a drilling rig triggers an alarm, video of the relevant equipment or 
perimeter will appear on the operators' CitectSCADA screen. This will enable the 
operators to make a context-sensitive assessment of the event by linking visual 
information to I/O data.  
 

What Is an IP 
Camera? 

How Does it 
Work? 

Video Surveillance 
in SCADA 
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Supported Cameras 
 

Pelco is one of the world leaders in the design, development and manufacturing of 
video and security systems and equipment for any industry. 
 
 

The Pelco Viewer is restricted to Pelco IP cameras only and particularly, a model of 
fixed cameras, Spectra IV Series IP and the Sarix range of cameras. 

 

The Pelco Viewer Version 3.0 operates with Pelco IP cameras that have been 
launched before February 2011. The following camera models have been tested: 

Camera Model 
Fixed IP Camera IP 3701 

Spectra IV Dome Spectra IV-IP 

Spectra IV PND 35X Spectra IV-IP 

Sarix IXE20C 

Sarix IX10DN 

Sarix IXS0DN 

Spectra HD Sarix D5118 

 
 

Pelco 

Pelco IP Cameras 
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Supported Cameras (cont.) 
 

There are two types of Pelco IP cameras that can be interfaced and controlled in 
CitectSCADA: fixed cameras and PTZ cameras. 

A fixed camera is a camera for which the viewing direction is not adjustable. It is 
set once the camera is mounted, and remains fixed. It is the traditional camera type, 
where the camera and the direction in which it is pointing are clearly visible. 

A PTZ camera (Pan, Tilt and Zoom camera) can be remotely steered to access a 
different field of view. It can manually or automatically pan right and left, tilt up 
and down, and zoom in and out of an area or object.  
 

Camera types 
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System Requirements 
 

Before installing and running the Pelco Viewer, the computer that will be used to 
view video streaming on a SCADA graphics page needs to meet minimum 
hardware and software requirements.  
 

 
SYSTEM STABILITY 

The Pelco Viewer ActiveX control should be installed on a SCADA display client to 
avoid additional CPU and memory overhead on the SCADA server. 

Failure to follow these instructions can result in death, serious injury or 
equipment damage. 

 
 
 
 
 
 

The Pelco Viewer has been designed for machines with the following software:  

Supported operating systems: 

 Windows XP Professional with Service Pack 3 (32 Bit and 64 Bit) 
 Windows Vista® with Service Pack 2 (32 Bit and 64 Bit) 
 Windows® 7 with Service Pack 1 (32 Bit and 64 Bit) 
 
 
 
 

Other software: 

 CitectSCADA version 7.0 or later 
 Microsoft® .NET Framework 3.5 SP1* 
 Microsoft Visual C++ 2008 Redistributable SP1* 
 A Local Area Network (LAN) if the client needs to access a remote server 
 Microsoft DirectX 9.0* on Windows XP and Microsoft DirectX 10* on 

Windows Vista or later 
 SafeNet SentinelTM key protection 

 Note: 

The Microsoft applications above (marked with an asterisk) are automatically 
installed on the computer during the Pelco Viewer installation as required. The 
computer needs to be connected to the Internet for the applications to be 
downloaded and installed. 
 

Before the 
Installation of the 
Pelco Viewer 

Software 
Requirements 
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System Requirements (cont.) 
 

The Pelco Viewer is a resource intensive component. It is recommended to run the 
Pelco Viewer on dedicated CitectSCADA display clients that meet the following 
hardware requirements:  
 

Description Minimum Specification 
Processor Intel Pentium 4 

Processor Speed 2 GHz 

Random Access Memory (RAM) 1 GB 

Graphics Adapter 256 MB dedicated video memory 
 
 
 
 

Description Recommended Specification or 
Higher 

Processor Intel CoreTM 2 Duo CPU E7500 

Processor Speed 2.93 GHz 

Random Access Memory (RAM) 4 GB 

Graphics Adapter ATI Radeon HD 3450 - Dell Optiplex 

NVDIA GeForce Go 7400 

ATI Radeon HD 3450 Pro 

1 GB or more dedicated memory 
 
 
 
 
 
 

Video streaming requires substantial use of dedicated CPU and memory resources, 
especially dedicated on-board video memory. 

 
POOR PERFORMANCE 

• The Pelco Viewer requires a graphics adapter with sufficient video 
memory as indicated in the table below. 

• Ensure that no more than four concurrent video sessions are streamed on 
a single SCADA graphics page. 

Failure to follow these instructions can result in death, serious injury or 
equipment damage. 

 
 
 
 

Depending on the computer’s dedicated video memory, users should experience 
reasonable video stream quality, performance, and responsiveness providing that 
number of concurrent video streaming controls on the same page does not exceed 
the number in the table below. 

Graphic Card Dedicated 
Video Memory 

Maximum Number of Concurrent 
Video Streaming 

256 MB 1 - 2 

512 MB 3 - 4 
 
 

Hardware 
Requirements 

Video Streaming 
Performance 
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The Pelco Viewer Installation 
 

The Pelco Viewer is an ActiveX component which can be inserted into a SCADA 
graphics page and configured with relevant camera properties. It provides a 
streaming interface which allows operators to view live video feed at runtime and 
interact manually or automatically with the camera(s). 

 Further Training: 

ActiveX objects within CitectSCADA are covered in greater depth in the 
CitectSCADA Configuration and CitectSCADA Customisation & Design 
Courses. 
 
 
 

 To install the Pelco Viewer ActiveX control: 

Run Setup.exe from the Pelco Viewer Version 3.0.0 installation zip folder. 
Follow the onscreen prompts to complete installation of the control. 

 Note: 

After a successful installation, the documentation is available from the Windows 
Start menu: Start » Programs » Schneider Electric » Pelco » Pelco User Guide. 
 

ActiveX 

How to Install the 
Pelco Viewer? 
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Exercise - Install the Pelco Viewer 

1 Install the Pelco Viewer ActiveX control 

i. Open the Pelco Viewer Version 3.0.0 zip folder. 

ii. Start the installation of the control by running Setup.exe. 

iii. The following dialog will appear. Click Next > to continue. 

 

iv. Follow the onscreen prompts to complete the installation of the 
ActiveX control by clicking Next.  

v. Click Close to terminate the installation. 
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Connection to a Camera 
 

To test the integration of Pelco cameras in the SCADA system, two Pelco 
Example projects have been included in the installation:  

 PelcoExample720 for CitectSCADA v7.20 
 PelcoExample700 for CitectSCADA v7.0 and above 

 Note: 

Pelco Example projects are provided in XP Style (compatible with CitectSCADA 
v7, v7.10 and v7.20) and Tab Style (compatible with CitectSCADA v7.20). They 
can be found in the Projects sub folder of your chosen installation folder. For 
training purposes, the PelcoExample720 project is used throughout this manual. 

These projects give examples of interfaces with one, two and four cameras, the 
Sarix camera, and a Camera Management page.  
 

The Pelco 
Example Project 
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Exercise - Restore the Pelco Example Project 

1 Start the Citect Explorer. 

i. From the Windows Start menu, select Programs » Citect » 
CitectSCADA 7.20 » CitectSCADA Explorer. 

2 Restore the PelcoExample720 project. 

i. In the Citect Explorer, click the Restore  button. 

ii. The following dialog will appear, use Browse… to select the Backup 
file if it is not already selected and then select New project. 

 
 
 
 
 

 
LOSS OF DATA 

• Do not restore the project in the Current project you are working on, as 
the currently selected project in the Citect Explorer will be overwritten.  

• Any project must be restored to a New project. 

• Give a new name to the project. The name must be unique. 

Failure to follow these instructions can result in property damage. 
 
 
 
 

 
HARD DISK DRIVE ERASURE 

Do not set the Restore Project path to the root directory of your drive (usually C:\). 

Failure to follow these instructions can result in property damage. 
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Exercise - Restore the Pelco Example Project 
(cont.) 

 

iii. Click OK to restore the PelcoExample720 project. 

iv. This dialog appear. Click Yes. 

 

v. Click OK when the Restore Complete dialog is displayed. 
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Exercise - Connect to a Camera 

1 Compile the project and run the Computer Setup Wizard. 

i. Select the menu File » Compile. 

 Note: 

When the project is compiled, CitectSCADA checks for errors.  If the compiler 
reports any errors, select Goto to display the place where an error exists.  When all 
errors have been corrected, save the page and compile again. 

ii. Click the Computer Setup Wizard  button on the Citect Graphics 
Builder toolbar. 

iii. Select Express Setup mode.  

iv. Select the PelcoExample720 project from the drop down list. 

v. Select Server and Control Client. 

vi. Select Stand alone. 

vii. Click Finish to complete the setup and save changes. 

2 Run the project. 

i. Select the PelcoExample720 project in the Citect Explorer project 
list. 

ii. Go to the Citect Project Editor. Select the menu File » Compile. 

iii. Click the Run Project  button in the Citect Project Editor. The 
Startup page of the PelcoExample720 project should be displayed. 
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Exercise - Connect to a Camera (cont.) 

3 Open the One Camera page. 

i. From the tabbed menu bar above, select the Pages tab. 

ii. Navigate to the One Camera page by clicking the 1Camera button in 
the Pages menu bar.  

   

iii. The One Camera page will be displayed. 

 

4 Configure the camera properties. 

i. Click the Ip Address  button.  

 

ii. Enter the IP address of the camera as advised by the Instructor (or 
of an available Pelco camera) in the dialog. 
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Exercise - Connect to a Camera (cont.) 

iii. Click OK.  

iv. Retain the displayed value for the other camera properties. 

 See Also: 

Some camera properties, like Port and Camera Number, have default values. For 
further information about the Pelco Viewer ActiveX control interface properties, 
see Interface Properties (page 3-18). 
 

5 Connect the Pelco Viewer to the camera. 

i. Click the Connect button. 

 

ii. Observe that video from the camera is streamed through the Pelco 
Viewer interface. The Pelco Viewer is connected to the camera. 
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Exercise - Connect to a Camera (cont.) 

iii. Navigate to the Two Cameras page and connect the left Pelco Viewer 
to the camera using the same properties. 

iv. Confirm that the left Pelco Viewer interface is showing live video from 
the camera. 

6 Disconnect the Pelco Viewer from the camera. 

i. Click the Disconnect button. 
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Pan, Tilt and Zoom Controls 
 

The Pelco Viewer interface includes a Pan, Tilt and Zoom (PTZ) toolbar which 
allows the camera to be controlled using the mouse. This toolbar appears at the 
bottom of the viewer window. 

 

The PTZ toolbar has the following controls: 

Icon Description 

 
These controls enable the camera to pan right or left. 

 
This control stops the pattern, tour, scan, pan or tilt operations. 

 
These controls enable the camera to tilt up or down. 

 
This control moves the camera to the home position. 

 
These controls enable the camera to zoom in or out. 

 
These controls enable the camera to focus near or far. 

 

These controls enable the camera to progressively close or open the 
iris. The iris is an adjustable aperture used to control the amount of 
light coming through the lens. The more the iris is opened, the more 
light it lets in and the brighter the image will be. 

 

 Note: 

The PTZ toolbar can be hidden or shown according to user's preference. Right-click 
in the viewer window and click Show/Hide Toolbar on the popup menu toolbar. 
 

 See Also: 

For further information about pattern, tour and scan operations, see Pattern 
Operation (page 2-21), Tour Operation (page 2-22) and Scan Operation (page 2-
22). 
 

PTZ Toolbar 
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Pan, Tilt and Zoom Controls (cont.) 
 

 
 
 
 

 
CAMERA CONTROL CONFLICT 

• If the Pelco cameras are being controlled exclusively through the SCADA 
system then ensure your SCADA system is designed to allow only one 
operator to perform operations on a camera at a time. 

• If the Pelco cameras are being controlled independently by multiple 
systems (e.g. SCADA and Security) then ensure that you have a clear 
documented and communicated process in place to ensure no camera 
conflict occur. 

Failure to follow these instructions can result in death, serious injury or 
equipment damage. 

 
 
 
 
 
 

The Pelco Viewer allows the camera to be directly controlled using the mouse. 

 To move the camera using mouse controls: 

In the Pelco Viewer interface: 

Mouse Action Description 
Drag the mouse pointer to the 
right or left... 

...enables the camera to pan in the opposite 
direction (than the mouse pointer). 

Drag the mouse pointer up or 
down... 

...enable the camera to tilt in the opposite 
direction (than the mouse pointer). 

Rotate the mouse wheel button 
forward (or backward)... 

...enables the camera to zoom in (or out). 

 

 Note: 

The ReverseTilt property enables users to reverse the tilt direction and have the 
camera panning or tilting in the same direction than the mouse pointer is dragged 
to.  
 

 Note: 

Mouse controls for Spectra HD Sarix cameras may have slow response times. To 
avoid this, use the PTZ toolbar controls instead. 
 

PTZ Toolbar 
(cont.) 

Mouse Controls 
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Exercise - Control a PTZ Camera 

1 Switch to a PTZ Camera. 

i. Return to the One Camera page. 

ii. Click the Ip Address button. 

  

iii. Enter the IP address of a PTZ camera (as advised by the Instructor 
or as available) in the dialog that just popped up, and click OK. 

iv. Click the Connect  button and confirm that video is streamed 
through the SCADA runtime page. 

 

v. Observe that the viewer window includes a PTZ toolbar. 

 

2 Control the camera position and manage the quality of the video. 

i. Use the Pan, Tilt and Zoom controls on the PTZ Toolbar and check 
that: 

 The camera pans right and left and tilts up and down. 

 The camera zooms in and out. 

ii. Drag the mouse pointer in the viewer window and check that: 

 The camera pans right and left and tilts up and down. 

 The camera zooms in and out. 

iii. Adjust the image brightness and sharpness by clicking the 
corresponding icons on the PTZ toolbar. 

3 Move the camera back to its home position. 

i. Click the proper icon on the PTZ toolbar to move the camera to its 
home preset position. 
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Further Controls and Viewing Features 
 

Additional controls and configuration of camera features are available in the popup 
menu toolbar. It includes the following menu options: Pattern, Preset, Scan, Tour, 
and Operations; as well as the option to hide or show the PTZ toolbar and the Status 
bar in the Pelco Viewer interface. 

 Note: 

The Pattern, Preset, Scan and Operations menus will only appear when 
connected to a Spectra IV camera equipped with PTZ functions. The Tour menu 
will only appear when connected to a Sarix camera equipped with PTZ functions.  
 
 

 To display the popup menu toolbar: 

Right-click the Pelco Viewer interface. 

 
 
 

A preset is a particular set of pan, tilt and zoom settings to a camera that was 
defined beforehand. In simpler words, a preset refers to a pre-defined camera 
position and zoom. 

The Preset menu allows the operator to set, run and delete a preset or a home 
position. 

 
 

The Popup Menu 
Toolbar 

How to Display 
the Popup Menu 
Toolbar? 

Preset Operation 
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Further Controls and Viewing Features (cont.) 
 

 To run a specified preset 

Right-click the viewer window to display the popup menu toolbar. Select the menu 
Preset » Run. 

Enter the desired preset number in the Select Preset dialog that just appeared, and 
click OK. 

 To configure a new preset 

Define the camera position using the pan, tilt and zoom controls of the PTZ toolbar 
or using the mouse.  

Select the menu Preset » Set from the popup menu toolbar.  

Enter a preset number in the Modify Preset dialog that just popped up, and click 
OK.  

 To run the configured Home preset 

Select the menu Preset » Home from the popup menu toolbar. 

 To configure the Home preset 

Select the menu Preset » Configure Home Preset from the popup menu toolbar.  

Enter the preset number that is to represent the home position in the Configure 
Home Preset dialog that just popped up, and click OK.  

 To delete a preset 

Select the menu Preset » Delete from the popup menu toolbar.   

Enter the preset number that is to be deleted in the Delete Preset dialog that just 
popped up, and click OK.  
 

How to Operate 
Presets? 
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Further Controls and Viewing Features (cont.) 
 

A pattern is a sequence of pan, tilt and zoom settings to a camera that was defined 
beforehand. It refers to pre-defined camera movement and zoom action over a 
period of time. 

The Pattern menu allows the operator to record, run or end a pattern. 

 
 
 

 To run a specified pattern 

Right-click the viewer window to display the popup menu toolbar. Select the menu 
Pattern » Run. 

Enter the desired pattern number in the Select Pattern dialog that just appeared, 
and click OK. 

Click the Stop  icon in the PTZ toolbar to stop the pattern operation. 

 To record a new pattern 

In the popup menu toolbar, select the menu Pattern » Record.  

Enter a pattern number in the Modify Pattern dialog that just popped up, and click 
OK.  

Then, create a pattern by controlling the movement and zoom action of the camera 
using the PTZ toolbar or the mouse controls.   

To stop the current recording process, select the menu Pattern » End Record from 
the popup menu toolbar. 
 

Pattern 
Operation 

How to Operate 
Patterns? 
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Further Controls and Viewing Features (cont.) 
 

Like a pattern, a scan is a pre-defined sequence of pan settings to a camera. 

The Scan menu allows the operator to run a scan. There are three built-in scan 
sequences: 

- Auto: it continuously rotates the camera 360 degrees. 

- Frame: it continuously rotates the camera horizontally in 90-degree 
increments. 

- Random: it continuously rotates the camera horizontally in random 
increments. 

 

 To run a scan: 

Right-click the viewer window to display the popup menu toolbar. Select the menu 
Scan » Scan Auto (or Scan Frame or Scan Random).  
 
 

A tour is a sequence of group of predefined camera presets that was defined 
beforehand. 

The Tour menu allows the operator to run a tour. 

 To run a tour: 

Right-click the viewer window to display the popup menu toolbar. Select the menu 
Tour » Run. Enter the tour name in the dialog that just popped up, and click OK.  

 See Also: 

Tours needs to be created using the camera's web interface. For more information, 
please refer to the Sarix Camera user manual. 
 
 
 
 
 
 

The Operations menu allows the operator to pan the camera 180 degrees from its 
current position or back to its zero position. 

 To run another operation: 

Right-click the viewer window to display the popup menu toolbar. Select the menu 
Operations » Rotate 180 Degrees or Pan to Zero. 
 

Scan Operation 

Tour Operation 

Other Operations 
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Exercise - Record and Run a Pattern 

1 Record a new pattern. 

i. On the One Camera page, right-click the viewer window to display 
the popup menu toolbar. 

ii. Select the menu Pattern » Record. The following dialog should 
appear. 

 

iii. Enter the number 5, and click OK.  

 Note: 

For training purposes, the pattern number 5 is recorded. Even though the Pelco 
Viewer supports an unlimited number of patterns, the camera itself may only allow 
a certain number of patterns. For further information, please refer to the Pelco 
Camera documentation. 

iv. Create a pattern using the pan, tilt and zoom controls of the camera. 

v. When the pattern recording process of the camera is over, select the 
menu Pattern » End Record from the popup menu toolbar. 

2 Test the previous pattern recording. 

i. Right-click the viewer window to display the popup menu toolbar.  

ii. Select the menu Pattern » Run.  

iii. Enter the number of the newly recorded pattern in the Select Pattern 
dialog that popped up. 

 

iv. Click OK. 

v. Confirm that the running pattern is the one that has just been 
recorded. 

vi. Let the pattern operation terminate or click the Stop  icon in the 
PTZ toolbar. 
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Exercise - Set and Run a Preset 

1 Configure a new preset. 

i. Using the mouse controls or the pan, tilt and zoom controls of the 
PTZ toolbar, define the camera position and zoom level. 

ii. When the camera settings are set, right-click the viewer window to 
display the popup menu toolbar and select the menu Preset » Set.   

iii. The Modify Preset dialog should appear.  

 

iv. Enter the number 7 and click OK. 

 Note: 

For training purposes, the preset number 7 is recorded. Even though the Pelco 
Viewer supports an unlimited number of presets, the camera itself may only allow a 
certain number of presets. For further information, please refer to the Pelco Camera 
documentation. 
 

2 Change the camera position and test the newly configured preset. 

i. Change the pan, tilt and zoom settings of the camera using the PTZ 
toolbar or the mouse. 

ii. Select the menu Preset » Set from the popup menu toolbar. 

iii. Enter the number of the new preset in the Select Preset dialog. 

 

iv. Click OK. 

v. Observe that the camera moved from its current position to the 
configured preset. 

3 Disconnect the PTZ camera. 
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Summary 
 

The following topics have now been addressed: 

 IP Cameras and Video Surveillance (page 2-2) 
 Supported Cameras (page 2-3) 
 System Requirements (page 2-5) 
 The Pelco Viewer Installation (page 2-7) 
 Connection to a Camera (page 2-9) 
 Pan, Tilt and Zoom Controls (page 2-16) 
 Further Controls and Viewing Features (page 2-19) 
 
 

The following questions are to check understanding: 

 An IP camera can be described as the combination of two components. Name 
them and explain their respective role. 

 What is the difference between a fixed camera and a PTZ camera? 
 Which property plays a key role to connect a camera from a CitectSCADA 

project? 
 Which tools allow the user to change the position and zoom settings of a 

camera via the Pelco Viewer interface? 
 Name and briefly describe two of the menu options available from the popup 

menu toolbar.  
 

Summary 

Questions 





 

 

Overview 
 

There are three ways of connecting to, viewing and controlling a Pelco camera in a 
CitectSCADA project. The quickest way is to place the Pelco Viewer ActiveX 
control on a graphics page during design time and then to configure it directly. It 
can also be done at runtime using tag association or Cicode. 
 

By the end of this chapter, students will be able to: 

 Find the IP address and port of a Pelco camera and test the camera video 
streaming. 

 Name and define at least four interface properties. 
 Create a Pelco Viewer ActiveX control in a graphics page and configure basic 

interface properties. 
 Create camera control objects in the page. 
 Use event-triggered display features. 
 

This Chapter Covers These Topics: 

 Find Camera Properties .......................................................... 3-2 

 Prepare to Stream Video ........................................................ 3-5 

 Add a Pelco Viewer ActiveX Control to a Page .................. 3-10 

 Configure the Pelco Viewer During Design Time ............... 3-13 

 Connect to and Configure a Camera at Runtime ................. 3-16 

 Customised Camera Controls ............................................... 3-23 

 Event-Triggered Display Feature ......................................... 3-27 
 
 

Chapter 3: Configuring the Pelco Viewer 

Introduction 

Learning Outcomes 
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Find Camera Properties 
 

The Pelco Device Utility is an application that allows the user to determine the IP 
address of a camera as well as to check the availability of a camera from a 
computer. 

 Hints & Tips 

Checking the availability of a camera from a computer may also be done using 
Internet Explorer®, by entering the camera's IP address in the URL field. 

The Pelco Device Utility can be found on the resource CD which is shipped with 
the camera. 

 

 See Also: 

For further information about how to install the Pelco Device Utility, please refer 
to the Pelco camera's documentation. 
 
 
 
 
 
 

 To find the camera's IP address 

Select the Pelco Device Utility item from the Windows Start menu: 

Start » Programs »  Pelco » Device Utility » PelcoDeviceUtility. 

The camera's IP address will be shown after the Pelco Device Utility has started. If 
the camera's IP address is not shown, then click the Search Now button and the 
camera should be detected by the utility. 
 

The Pelco Device 
Utility 

How to Find the 
Camera's IP 
Address? 
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Exercise - Check Camera Availability 

1 Access to the camera page. 

i. Open Internet Explorer from the Windows Start menu. 

ii. Enter the camera's IP address in the URL field as advised by the 
Instructor (or as detected by the Pelco Device Utility). 

 

 See Also: 

For further information about the Pelco Device Utility, please refer to The Pelco 
Device Utility (page 3-2). 

 

iii. The Login page will be displayed. 

iv. Log in with the default user ID and password. Enter admin in both 
fields. 

 

v. After the first successful login, the following dialog will pop up.  

 

vi. Accept the prompt to install the ActiveX control and click Install.  
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Exercise - Check Camera Availability (cont.) 

2 Check the camera availability. 

i. Confirm that the camera is connected and that video is streamed in 
the browser. 

ii. Confirm that streamed video is displayed on the page: 

 

3 Close Internet Explorer. 
 

 See Also: 

For further information about lack of camera connection, please refer to the 
PELCO Camera and SCADA Integration Guide - Troubleshooting. 
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Prepare to Stream Video 
 

Camera video rendering on the system may be tested by launching the Pelco 
Diagnostic Player. This tool is installed with the Pelco Viewer ActiveX control.  
 
 

 To launch the Pelco Diagnostic Player: 

Run Pelco Diagnostic Player.exe from the installed directory.  

or  

Select the Pelco Diagnostic Player item from the Windows Start menu: 

Start » Programs » Schneider Electric » Pelco » Pelco Diagnostic Player. 
 
 

When the Pelco Diagnostic Player starts, a console window is launched 
automatically. When the Pelco Diagnostic Player is closed, this application is also 
closed. 

 
 

Test the Camera 
Video Rendering 

How to Start the 
Pelco Diagnostic 
Player? 

The Pelco 
Diagnostic Player 
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Prepare to Stream Video (cont.) 
 

 To launch the Network Stream Settings: 

Click the Configuration  button at the bottom of the Pelco Diagnostic Player 
window. 

 

 Hints & Tips 

Once the camera settings have been configured, live video will be streamed 
through the Pelco Diagnostic Player window.  

Click the Stop  button /  Play  button at the bottom of the Pelco Diagnostic 
Player window to disconnect the camera / connect it back. 
 

The Network 
Stream Settings 
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Prepare to Stream Video (cont.) 
 

There are two modes to connect to a camera: RTP and RTSP. 

Real-Time Transport Protocol (RTP) is an Internet protocol that supports end-to-
end real-time transmission of audio and video over IP networks. To connect to a 
camera using RTP mode, valid values for camera IP address, camera port and 
camera number (also referred to as ServiceID) need to be entered. 

Real-Time Streaming Protocol (RTSP) is an application-level protocol that uses 
RTP for both control and on-demand delivery of real-time multimedia data. To 
connect to a camera using RTSP mode, the following RTSP URL need to be 
entered: RTSP://<IP Address>/stream1. 

Sarix cameras have an RTSP server in the camera. Thus RTSP mode needs to be 
used to connect to a Sarix camera in the Pelco Viewer interface. 

 Note: 

Pelco IP cameras usually have factory default port numbers of either 49152 or 
49157. The default camera number is 1. If the camera is used in conjunction with 
a Pelco DVR (Digital Video Recorder), the camera number is assigned on the 
DVR. 
 
 

The camera streaming type in RTP mode can be either unicast or multicast.  

A unicast connection sends a separate video stream from the camera to each Pelco 
Viewer (client), whereas a multicast connection sends a video stream to multiple 
Pelco Viewer (clients) at the same time using one, shared transmission stream. 

 To get a unicast connection: 

Select the Unicast check box in the Network Stream Settings dialog and enter valid 
entries for local IP address and local port (default is 9102). 
 

Modes of 
Connection 

Camera 
Streaming Types 
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Exercise - Verify Camera Video Rendering 

1 Launch the Network Stream Settings. 

i. Select the Pelco Diagnostic Player item from the Windows Start 
menu: Start » Programs » Schneider Electric » Pelco » Pelco 

Diagnostic Player.Click the Configuration  button at the bottom 
of the Pelco Diagnostic Player window. 

ii. The Network Stream Settings dialog will appear. 

 
 

 
DELAYED OR INCORRECT VIDEO 

Ensure that cameras are configured to overlay the time-stamp and camera 
information on the video stream to assist operators in correctly identifying the 
camera and the time at which the image was relayed. 

Failure to follow these instructions can result in death, serious injury or 
equipment damage. 
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Exercise - Verify Camera Video Rendering 
(cont.) 

2 Test the camera video rendering. 

i. Type the camera's IP address in the Camera IP field, as advised by 
the Instructor (or as available). 

ii. Leave the default values in the Camera Port and ServiceID fields 
and ensure the Unicast check box is clear. 

iii. Click the Connect button. 

iv. Confirm that the Pelco Diagnostic Player display live video streamed 
from a camera. 

 

3 Close the Pelco Diagnostic Player. 
 

 Note: 

If the Pelco Diagnostic Player is not showing live video image from the camera that 
it is connected to, then the camera is not connected. Verify that all required 
software is installed on the system and that the correct IP address and port are used. 
 

 See Also: 

For further information about lack of camera connection, please refer to the 
PELCO Camera and SCADA Integration Guide - Troubleshooting. 
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Add a Pelco Viewer ActiveX Control to a Page 
 

The Pelco Viewer ActiveX control may be incorporated into the graphics page of a 
CitectSCADA project, allowing users to configure the camera properties directly. 

 To insert a Pelco Viewer ActiveX object via the Graphics Builder 

The Pelco Viewer ActiveX control may be inserted into a CitectSCADA project via 

the Citect Graphics Builder, by using the Add Pelco Viewer ActiveX  button 
from the Graphics Builder toolbox.  
 

Insert a Pelco 
Viewer ActiveX 
Control into a Page 
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Exercise - Insert a Pelco Viewer ActiveX into a 
Page 

1 Create a new graphics page to place the Pelco Viewer interface. 

i. Open the Citect Graphics Builder, click the New  button. 

ii. Click the Page button when the following dialog is displayed: 

 

iii. Use the following template settings: 

Style tab_style_1 

Linked  

Title bar  

Resolution XGA 

Template Normal 
 
 
 

iv. Click OK to create a new page based on the Normal template. 
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Exercise - Insert a Pelco Viewer ActiveX into a 
Page (cont.) 

2 Use the Add Pelco Viewer ActiveX button from the Citect Graphics 
Builder toolbox to insert a Pelco Viewer ActiveX into a page. 

i. Save the new page as MyCameraInterface page. 

ii. Click the Add Pelco Viewer ActiveX  button on the Graphics 
Builder toolbox. 

iii. The Pelco Viewer will be added to the graphics page.  

iv. The Pelco Viewer 3.0 Properties dialog will pop up automatically. 
Click Cancel to close it as no configuration is required. 

The page will look like this: 

 

v. Save the page. 
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Configure the Pelco Viewer During Design Time 
 

When the Pelco Viewer ActiveX control is added to a graphics page during design 
time, the Pelco Viewer Properties dialog pops up automatically.  

This dialog contains the properties for the Pelco Viewer: 

 

 
INCORRECT VIDEO DISPLAYED 

Ensure that continuous port numbers are not used for multiple cameras on the 
same page when using unicast stream. 

Failure to follow these instructions can result in death, serious injury or 
equipment damage. 

 
 
 
 
 
 

 To configure the Pelco Viewer properties during design time: 

Open the Pelco Viewer Properties dialog.  

In the Access (Identification) tab, set the Object Name. 

In the Appearance (Camera Connection Settings) tab, provide the camera 
configuration details.  

 Hints & Tips 

To automatically connect the camera to the viewer window upon start, select the 
Automatically connect to a camera check box. 
 

Configure Pelco 
Viewer Properties 

During Design 
Time 
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Exercise - Configure the Pelco Viewer During 
Design Time 

1 Configure the camera's configuration properties. 

i. Return to the Citect Graphics Builder.  

ii. In the MyCameraInterface page, open the Pelco Viewer 3.0 
Properties by double-clicking the viewer window. 

iii. On the Appearance (Camera Configuration Settings) tab, provide 
the camera configuration details as advised by the Instructor (or as 
available) and select the Automatically connect to a camera check 
box  
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Exercise - Configure the Pelco Viewer During 
Design Time (cont.) 

iv. Open the Access (Identification) tab. Set the Object Name to 
PelcoCam and select the Persist ActiveX data between page 
transitions check box. 

 

 Hints & Tips 

To save the state of an ActiveX control (properties set from Cicode) when switching 
between pages, select the Persist ActiveX data between page transitions check 
box.  

v. Click Apply and then OK to save the configuration of the Pelco 
Viewer ActiveX object. 

2 Test the changes. 

i. Compile and run the project. 

ii. Navigate to the MyCameraInterface page and confirm that there is 
video streamed from the camera in the Pelco Viewer. 

3 Shutdown the project. 
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Connect to and Configure a Camera at Runtime 
 

To be able to connect to a Pelco camera from the Pelco Viewer interface at runtime, 
the camera connection information needs to be passed to an object in the Pelco 
Viewer ActiveX control. To do so, properties for each cameras are to be stored in 
variable tags defined within CitectSCADA, which will be associated with Pelco 
Viewer ActiveX control properties. 
 
 

 To define variable tags for camera properties: 

Open the Citect Project Editor, select the menu Tags » Variable Tags  

or  

Click the Variable Tags  button on the toolbar. 

For each camera properties, enter the Variable Tag Name, I/O Device Name, Data 
Type, and Address in the fields. 

Click Add to append a new record. 

 Further Training: 

Variable Tags is a topic in the CitectSCADA Configuration Course. 
 

 See Also: 

For further information about Pelco Viewer interface properties, please see 
Interface Properties (page 3-18). 
 

Using Tag 
Association 

Create Tags for 
Camera Properties 
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Connect to and Configure a Camera at Runtime 
(cont.) 
 

 To map variable tags to Pelco Viewer properties: 

In the Citect Graphics Builder, double click the Pelco Viewer ActiveX control to 
open the Pelco Viewer Properties dialog.  

Select the Appearance (Tag Association) tab.  

Select the check box of a property from the Properties list. Then, either select the 
variable tag to be associated with a property, by clicking on the Wizard button and 
choosing from the list of available tags, or type the tag name directly in to the 
Associate property with tag... field.  

Click OK to apply the changes and close the dialog.  

 Further Training: 

Tag Association is a topic in the CitectSCADA Customisation and Design 
Course. 
 

 See Also: 

For further information about Tag Association, see CitectSCADA Help - ActiveX 
Object Properties - Appearance (Tag Association). 
 

Map Tags to 
Properties 
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Connect to and Configure a Camera at Runtime 
(cont.) 
 

The following properties can be used to connect to, manage and control Pelco IP 
cameras at runtime in various ways, from video streaming, PTZ control speed and 
other properties. 

Property Role 

AutoConnect 
To specify the camera auto connection settings, i.e. 
whether to automatically connect to configured camera 
when the page is loaded at runtime or not. 

Bandwidth 
To specify the streaming video bandwidth 
constraints.  

CameraNumber To change the active camera being streamed.  

CameraIpAddress To specify the IP address of the Pelco camera where 
video is streamed from.  

CameraPortNumber To specify the port number of the camera. 

HomePresetId 
To specify the preset number for the camera home 
position. 

ReverseTilt To specify the reverse tilt functionality, i.e. whether or 
not to reverse the tilt direction when using the mouse. 

RtspMode To specify the streaming mode, either RTP or RTSP. 

RtspUrl To specify the RTSP URL, if the camera is a RTSP 
camera.  

UnicastStream To specify the camera streaming type, either unicast or 
multicast. 

UnicastStreamIP To define the IP address of the local computer to 
which the Pelco device will stream the video. 

UnicastStreamPort 
To specify the port that the Pelco device will use for 
unicast listening for the video. 

VelocityHorizontal To specify the camera pan speed. 

VelocityVertical To specify the camera tilt speed. 
 

 See Also: 

For further information about the Pelco Viewer ActiveX control interface 
properties (including data type, allowable and default values for each property), 
please refer to the Pelco Camera and SCADA Integration Guide - Pelco Viewer 
ActiveX Control Interface Properties. 
 

Interface 
Properties 
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Connect to and Configure a Camera at Runtime 
(cont.) 
 

An alternate way to connect to and control a Pelco camera at runtime is to use the 
interface methods that come with the Pelco Viewer which may be accessed via 
Cicode.  

Functions in an ActiveX object that can be called by CitectSCADA are known as 
methods. The Pelco Viewer ActiveX control methods are designed to enable users 
to control Pelco cameras automatically, including automatically switching cameras 
in a viewer, sending PTZ commands, and recording and running patterns etc.  

The main categories of Pelco Viewer methods are: 

 Connection methods 
 Customise user interface methods 
 PTZ methods 
 Preset methods 
 Pattern methods 

 See Also: 

For further information about Pelco Viewer methods, see PELCO Camera and 
SCADA Integration Guide - Pelco Viewer ActiveX Control Interface Methods. 
 

 Further Training: 

ActiveX Methods is a topic in the CitectSCADA Customisation and Design 
Course. 
 

Using Cicode 
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Exercise - Configure the Pelco Viewer Using Tag 
Association 

1 Define variable tags. 

i. Go to the Citect Project Editor. Select Tags » Variable Tags from the 
menu. The Variable Tags form will be displayed:  

 

ii. Define the three following variable tags by filling the fields of the 
form as follows and clicking Add to save each record: 

Variable Tag 
Name 

Data 
Type 

Cluster 
Name 

I/O Device 
Name 

Address 

IpAddress5 STRING Test TestIO s9 

CameraNumber5 LONG Test TestIO l15 

Port5 LONG Test TestIO l16 

2 Associate tags with the Pelco Viewer ActiveX object. 

i. Return to the Citect Graphics Builder and open the 
MyCameraInterface page. 

ii. Open the Pelco Viewer Properties dialog. 
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Exercise - Configure the Pelco Viewer Using Tag 
Association (cont.) 

iii. Open the Appearance (Camera Connection Settings) tab, and clear 
the Camera IP Address, Camera port and Service ID fields as well 
as the Automatically connect to a camera check box. 

 

iv. Open the Appearance (Tag Association) tab and associate the 
CameraIpAddress property with the STRING tag IpAddress. Make 
sure that the Update association on Event is <Property change 
notification>. 
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Exercise - Configure the Pelco Viewer Using Tag 
Association (cont.) 

v. Map tags to properties as shown in the table below. 

Property Associated Tag 

Bandwidth Bandwidth 

CameraNumber CameraNumber5 

CameraPortNumber Port5 
 
 
 

vi. Click OK and save the page. 

3 Compile the project. 
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Customised Camera Controls 
 

Additional genies have been developed and included in the PelcoExample720 
project to simplify project creation and customisation: 

 Function: this genie can be used to call functions inside the ActiveX control on 
the One Camera page. 

 SetValue: this genie can be used to create buttons and text objects to change 
the properties of a Pelco camera. 

 PelcoCameraSelector: this genie can be used to manage multiple cameras on 
the Pelco Camera Management page. 

These genies may be reused in any project. When a genie is pasted onto a page, a 
dialog box will request the entry of one or more variable tags and comments or 
other data, to control the display and actions of the genie object at runtime.  
 
 

 To paste a genie on to a graphics page: 

In the Citect Graphics Builder, click the Paste Genie  tool. 

or 

Select the menu Edit » Paste Genie… 
 

Create Control 
Buttons and Objects 

How to Insert a 
Genie? 



3-24 Pelco Viewer Version 3.0  July 2011 
 

 

Exercise - Add Customised Buttons 

1 Paste genies onto the MyCameraInterface page to change the 
camera connection properties at runtime. 

i. Click the Paste Genie  button in the Graphics Builder toolbox. 

ii. From the genie library select the SetValue genie. 

 

iii. Click OK. 

iv. In the following dialog, enter IP Address in the label field and 
IpAddress5 (i.e. the associated variable tag) in the var field. 

 

v. Click OK and move the genie to the top right of the Pelco Viewer 
interface. 

vi. Insert two other genies below the first one, enter the following labels 
and variable tags in the dialog: 

Label Port Camera Number 

Var Port5 CameraNumber5 
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Exercise - Add Customised Camera Controls 
(cont.) 

2 Insert genies onto the page to connect and disconnect the camera 
at runtime. 

i. Click the Paste Genie  button in the Graphics Builder toolbox. 

ii. From the genie library select the function genie and click OK. 

iii. The following dialog should pop up: 

 

iv. Enter the following data and variable tags in the dialog for the 
Connect button. 

Label Connect 

FunctionUp Connect 

Object PelcoCam 

FunctionDown Bandwidth 
 
 
 

v. Add a Disconnect button using these data and tags. 

Label Disconnect 

FunctionUp Disconnect 

Object PelcoCam 

FunctionDown  
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Exercise - Add Customised Camera Controls 
(cont.) 

The MyCameraInterface page will look like this: 

 

vi. Save the page. 

3 Test the changes. 

i. Compile and run the project. 

ii. Navigate to the MyCameraInterface page. Specify the camera 
connection properties as advised by the instructor (or as available), 
using the three buttons on the top right of the page.  

iii. Click the Connect button and verify that live video is streamed from 
the camera in the viewer window. 

iv. Click the Disconnect button and confirm that the connection to the 
camera is interrupted. 

4 Shutdown the project. 
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Event-Triggered Display Feature 
 

In the case of an incident occurring in a plant and an alarm being triggered, the 
Pelco Viewer can be configured so that video of the relevant equipment, perimeter 
or site will appear on the operators' CitectSCADA screen.  

The live video displayed can either confirm what the alarm indicates or show it to 
be erroneous. It can show the nature and scale of the problem more intuitively than 
I/O data alone and alert operators to the possible risks at the site.  
 
 

Alarmlink is another genie included in the PelcoExample720 project. It can be used 
to configure event-triggered display features in the Pelco Viewer. 

Alarmlink uses Cicode to run the "Preset" method provided by the Pelco Viewer 
ActiveX control programming interface. 

 See Also: 

For further information about Pelco Viewer methods, see PELCO Camera and 
SCADA Integration Guide - Pelco Viewer ActiveX Control Interface Methods. 
 

Alarm System and 
Camera Integration 

Alarmlink 
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Exercise - Configure the Alarm / Camera 
Integration 

1 Create a digital alarm tag. 

i. Go to the Citect Project Editor.  

ii. Select Tags » Variable Tags from the menu.  

iii. Fill in the Variable Tags form as below: 

Variable Tag 
Name 

Data 
Type 

Cluster 
Name 

I/O Device 
Name 

Address 

MyTag DIGITAL Test TestIO D6 
 
 
 
 

iv. Click Add to save the new record. 

2 Create and configure a digital alarm that will be integrated with 
the PTZ camera. 

i. In the Citect Project Editor, select Alarms » Digital Alarms from the 
menu. 

ii. Create a digital alarm by filling in the Digital Alarms form that just 
popped up as follows. Press F2 if the extended form is not already 
visible. 

 

Alarm 
Tag 

Cluster 
Name 

Alarm 
Name 

Alarm 
Desc 

Variable 
Tag A 

Custom 
Filter 8 

MyAlarm Test MyAlarm MyAlarm MyTag 7 
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Exercise - Configure the Alarm / Camera 
Integration (cont.) 
 

 Note: 

The Custom Filter 8 field has been configured in Cicode so as to store the preset 
number that the alarm is linked to. In this exercise, the idea is to link an alarm to the 
preset that was configured previously, see Exercise - Set and Run a Preset (page 2-
24). 
 

 

iii. Click Add to save the new record. 

3 Create a button to toggle the alarm at runtime. 

i. Return to the Citect Graphics Builder and open the 
MyCameraInterface page. 

ii. Click the Button  icon in the Graphics Builder toolbox and draw a 
button at the bottom left of the page. 
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Exercise - Configure the Alarm / Camera 
Integration (cont.) 

iii. Set the object properties as follows: 

Appearance (General) 
Text 

Alarm On/Off 

Input (Touch) 
Up Command 

Toggle(MyTag) 

Access (General) This button toggles the alarm 

 

iv. Click OK and save the page. 

4 Insert a Bitmap image to indicate whether the alarm is on or off at 
runtime. 

i. Open the One Camera page and copy one of the Bitmap image  that 

look like this: .  

ii. Go back to the MyCameraInterface page and paste the Bitmap 
image to the right of the Alarm On/Off button. 

iii. Open the Bitmap Properties dialog.  

iv. Open the Appearance (Visibility) tab and fill in the Hidden when 
field with: 

NOT (MyTag) 

v. Click OK and save the page. 

5 Insert an alarmlink genie. 

i. Click the Paste Genie  button in the Graphics Builder toolbox. 

ii. From the genie library select the alarmlink genie. 
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Exercise - Configure the Alarm / Camera 
Integration (cont.) 

iii. Click OK. 

iv. In the following dialog, enter the animation number 11 in the Alarm 
AN field.  

 

v. Click OK and move the genie to the right of the first line on the 
Alarms toolbar at the bottom of the page. 

 

vi. The MyCameraInterface page will look like this: 

 

vii. Save the page. 
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Exercise - Configure the Alarm / Camera 
Integration (cont.) 

 Note: 

The alarmlink function in Cicode is used to run the method called "Preset". 
 

6 Run the project then trigger the alarm and check the change of 
camera settings in the Pelco Viewer. 

i. Compile and run the project. 

ii. Navigate to the MyCameraInterface page and click the Connect 
button. 

 

iii. Change the camera position and zoom level using the PTZ controls to 
make sure that the camera is not pointing to the previously 
configured preset. 

iv. Click the Alarm On/Off button. The Active Alarm icon will start to 
flash. 

 

v. The Alarms toolbar at the bottom of the page will display the alarm 
that was just triggered. Click the alarmlink genie to the right. 

 

vi. Observe that the camera moved from its current position to the 
configured preset. 

7 Shutdown the project. 
 

 

 
 



Pelco Camera and 
CitectSCADA Integration 

Training Guide Release 1 3-33 

 

 

Summary 
 

The following topics have now been addressed: 

 Find Camera Properties (page 3-2) 
 Prepare to Stream Video (page 3-5) 
 Add a Pelco Viewer ActiveX Control to a Page (page 3-10) 
 Configure the Pelco Viewer During Design Time (page 3-13) 
 Connect to and Configure a Camera at Runtime (page 3-16) 
 Customised Camera Controls (page 3-23) 
 Event-Triggered Display Feature (page 3-27) 
 
 

The following questions are to check understanding: 

 What is the role of the Pelco Diagnostic Player? 
 What mode needs to be used to connect to a Sarix camera in the Pelco Viewer? 
 What steps should be taken to connect to and configure a Pelco camera from 

within CitectSCADA at runtime? 
 Name four interface properties used to connect to or control a camera and 

define them. 
 

Summary 

Questions 
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Overview 
 

This chapter covers the course summary and the next steps through the Educational 
Services curriculum. 
 

This Chapter Covers These Topics: 

 Summary - Pelco Camera and CitectSCADA Integration ..... 4-2 

 Further Training ..................................................................... 4-3 

 Examinations ......................................................................... 4-5 
 
 

Chapter 4: Training Summary 

Introduction 
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Summary - Pelco Camera and CitectSCADA Integration 
 

As the Pelco Camera and CitectSCADA Integration training is complete, students 
should be able to: 

 Install and configure the Pelco Viewer. 
 Connect to a Pelco IP camera and view live video feed in a CitectSCADA project. 
 Perform camera control operations like Pan, Tilt and Zoom (on cameras which 

support these features) at runtime. 
 Use event-triggered display features like Patterns, Presets etc. 
 Create a Pelco Viewer interface in a graphics page, configure basic camera 

properties and create camera control objects. 
 

Course Objectives 
Summary 
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Further Training 
 

Educational Services offers a variety of technical training courses to meet users' 
specific training requirements. Instructor-led courses provide hands-on experience, 
leaving the participant feeling confident to design and configure their own systems. 

Educational Services includes configuration and programming courses, update courses, 
and introductory courses for CitectSCADA, CitectHistorianTM and Unity Pro. 

The team has developed unique, step-by-step training that has proven highly effective, 
and the curriculum is continually updated, enabling students to stay in step with this 
rapidly changing technology. 

 
 

Next Steps in 
Training 



4-4 Pelco Viewer Version 3.0  July 2011 
 

 

Further Training (cont.) 
 

Educational Services offers the following courses: 

 CitectSCADA Configuration Course: Citect Configuration Environment, Project 
Management, Communications, Graphics, Operator Input, Genies, Popup Pages, 
Events, Alarms, Process Analyst, Page Management, Reports, Accumulators, 
Security, Introduction to Cicode, Multi-Language Projects, Design Specification. 

 CitectSCADA Upgrade Course: Upgrade a project to the latest version of 
CitectSCADA, Install Multiple Versions of CitectSCADA, CitectSCADA 
Architecture, Tag Extensions, Diagnostic Tools and New Templates. 

 Cicode Programming Course: Introduction to Cicode, Variable Operators, 
Cicode Editor, Cicode Functions, Conditional Executors, Structured Programming, 
Cicode Debugger 

 CitectSCADA Architecture and Redundancy Course: CitectSCADA 
Architecture, On-line Changes, Clustered Control System, CitectSCADA 
Redundancy, Web Client and Windows Integrated Security. 

 CitectSCADA Customisation and Design Course: Custom Templates, Smart 
Genies and Popup Pages, Forms, Exchanging Data with other Applications, 
Custom Alarm Filtering. 

 CitectSCADA Diagnostics and Troubleshooting Course: Network management 
and the kernel, Publish Subscribe Model of Communications, Cicode and the 
Kernel, System Logging Tools, Tag Extensions, System profile Tools and Network 
Analysis. 

 CitectHistorian Configuration Course: Installation, Connecting to HMIs, SQL 
Server®, Publishing Data, Historian, Backfill Manager, Security, Managing 
Projects, Displaying Information in Clients, SQL 2005 Reporting Services Design, 
Connecting to SQL Databases, Events, Tasks. 

 Unity Pro Configuration Course: The Unity Pro Interface, Managing Projects, 
Language Editors, Functional Block Diagram Language (FBD), Animation and 
Animation Tables, Graphics, Function Blocks, Sequential Function Chart (SFC), 
Project Maintenance and Documentation, Communications and OFS Server. 

Descriptions of all these courses are available on the Citect website. 
 

Course Offerings 
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Examinations 
 

The CEP program distinguishes and recognizes engineers skilled in the integration of 
Schneider Electric based automation projects, and encourages other engineers to move 
in this direction. At the heart of the CEP program is the CEP exam, which provides a 
means of testing experienced systems engineers. It encompasses tests for both 
CitectSCADA knowledge as well as a range of related topics such as PLC 
communications, Windows OS and networking. 

Further information regarding the CEP program is available on the Schneider Electric 
website. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

Certified Engineer 
Program 
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